Fwd: Bogofilter mailing list probe message

Bob Vincent bobvin at pillars.net
Sun Jul 18 21:41:29 EDT 2004


-------------------------------------------
Check 1: wallace.net.nz MX record

         Points to mail.wallace.net.nz.

Good.

-------------------------------------------
Check 2: mail.wallace.net.nz A record

         Points to 64.245.160.11

Good.

-------------------------------------------
Check 3: 11.160.246.64.in-addr.arpa PTR record

         Points to mail.wallace.net.nz.
         Points to www.rangers.wallace.net.nz.
         Points to mail.ceremony.co.nz.

Better than some, but not perfect.

RFC specifies that there can be only one PTR record
for each in-addr.arpa address.  You have three.

--------------------------------------------
Check 4: wallace.net.nz A record

         Does not exist.

Correct according to RFC, but some mailers will 
try delivering direct to the mail host before
looking up an MX record.  This, apparently, is
your problem.

----------------------------------------------
Check 5: Sample SMTP session (verbatim:)


$ telnet mail.wallace.net.nz 25
Trying 64.245.160.11...
Connected to mail.wallace.net.nz.
Escape character is '^]'.
220 mail.wallace.net.nz (IMail 8.11 52298-3) NT-ESMTP Server X1
helo mail.html.com.
250 hello mail.wallace.net.nz
mail from: <bob at html.com>
250 ok
rcpt to: <brenda at wallace.net.nz>
250 ok its for <brenda at wallace.net.nz>
data
354 ok, send it; end with <CRLF>.<CRLF>
From: Bob Vincent <bob at html.com>
To: Brenda <brenda at wallace.net.nz>
Subject: test

Test complete. (see bogofilter list for details)
.
250 Message queued
quit
221 Goodbye
Connection closed by foreign host.

-----------------------------------------------

On Sun, Jul 18, 2004 at 07:03:19PM -0400, David Relson wrote:
> Hi Brenda,
> 
> osagesoftware.com has been my primary domain for the past 5 years or so.
> It was assigned address block 216.144.204.40/29 when moved to my current
> DSL provider.  Until taking on bogofilter.org, I only used 1 address
> (216.144.204.42) which responds to a variety of names, like
> www.osagesoftware.com, dns..., mail..., etc.  Back in March, I assigned
> 216.144.204.43 to bogofilter.org's web pages and mailing lists.
> 
> The complaint indicates that my Postfix configuration doesn't like the
> configuration at your end.
> 
> >			The Postfix program
> >
> > <brenda at wallace.net.nz>: Host or domain name not found. Name service
> > error for
> >    name=wallace.net.nz type=A: Host found but no data record of
> >    requested type
> 
> You can get some additional information using zmailer.org's page for
> verifying email address, i.e. http://www.zmailer.org/mxverify.html.
> 
> As I'm a programmer and (of necessity) a rookie sys admin, I can't say
> for sure whether the problem is at your end or mine.  It might well be
> worth your while to check with your ISP, though odds are they'll say
> "not us; it's the other guy (postfix @ bogofilter.org)".  If anyone can
> shed light of this it would be helpful :-)
> 
> Regards,
> 
> David
> _______________________________________________
> Bogofilter mailing list
> Bogofilter at bogofilter.org
> http://www.bogofilter.org/mailman/listinfo/bogofilter
> 


More information about the Bogofilter mailing list