Problem after upgrade

Matthias Andree matthias.andree at gmx.de
Mon Jul 12 05:56:00 EDT 2004


"Markus T." <markus at trippelsdorf.net> writes:

>> file ./spamlist.db
> ./spamlist.db: Berkeley DB (Btree, version 9, native byte-order)
>> file ./goodlist.db
> ./goodlist.db: Berkeley DB (Btree, version 9, native byte-order)
>
>> 
>> Can you reinstall the older version (with RPM, pass --oldpackage) and
>> use the older bogoutil -d on your files? If so, save the output of
>> bogoutil -d, we'll then see how we load that into your new bogofilter
>> version.
>> 
> ~/.bogofilter $ db4_dump ./spamlist.db 
> db_dump: ./spamlist.db: unsupported btree version: 9
> db_dump: open: ./spamlist.db: Invalid argument
>
> ~/.bogofilter $ db4.1_dump ./spamlist.db 
> db_dump: ./spamlist.db: file size not a multiple of the pagesize

Strange, I've never seen such. Has the file been truncated? Does
"db4.1_dump -r ./spamlist.db" work?

-- 
Matthias Andree

Encrypted mail welcome: my GnuPG key ID is 0x052E7D95 (PGP/MIME preferred)


More information about the Bogofilter mailing list